Audiocodes SBA GUI Update Framework Error

Hallo an Alle,

kürzlich habe ich einige Audiocodes SBAs bei einem Kunden aktualisiert und folgenden Fehler erlebt.

Nach Audiocodes Vorgabe habe ich erst das GUI Update von Audiocodes installiert, um danach den Fehler zu erhalten, das eine Eigenschaft TargetFramwork nicht valide ist.

Nach einigen Tests und Recherche hier nun ein kurzes HowTo wie man das installieren und fixen kann. Ich habe nicht getestet ob, sich der Application Pool auch vor dem Update umstellen lässt und dann alles sauber durchläuft. Dies liefere ich ggf. in Kürze noch nach.

Installation des Updates:

Als ersten Schritt laden wir das aktuell GUI Update für die WebGUI unserer SBA von Audiocodes herunter. Dies bekommt Ihr nach Anmeldung (und nur mit gültigem Supportvertrag!) hier: http://www.audiocodes.com/downloads

Der erste Schritt ist nun mit einem unterstützten Browser auf die Webschnittstelle der SBA zu navigieren, um die aktuelle Version fest zu stellen.

01_Start

Wenn diese nun niedriger ist als die heruntergeladene Version wissen wir also, dass eine Aktualisierung nötig ist.

Die Aktualisierung wird nun ebenfalls über die Website der SBA durchgeführt. man meldet sich mit einem berechtigten Account an, navigiert zu Tools (1) auf der Linken Seite (Navigationsleiste), darin wählt man System Update (2). In dem PopUp Fenster hinterlegt man die heruntergeladene Datei (3) und mittels Klick auf „Apply“ übernimmt man das Update bzw. installiert es (4).

03_Upgrade

Nach einer kurzen Zeit wird man aufgefordert, dass das System einen nun abmeldet und die GUI aktualisiert wenn man auf „Apply“ klickt.

04_Apply

Nach dem Hinweis, dass das System nun aktualisiert kommt leider die Fehlermeldung, dass die Eigenschaft targetFramework=“4.0″ in der Web.config Datei nicht valide ist.

05_Error

Lösung des Problems:

Man verbindet sich via RDP, Monitor oder Console auf den Desktop der SBA und stellt, kurz gesagt, die .NET Framework Version des Application Pools im IIS für die Verwaltungswebsite von V2.0 auf V4.0.

Hier die detaillierten Schritte:

Im IIS Manager auf der SBA wir die Website lokalisiert (1.) und in den Basic Settings ermittelt um welchen Application Pool es sich handelt (2.).

06_Determine_AppPool

Im nächsten Schritt, wird in dem entsprechenden Application Pool die .NET Framework Version auf Version 4.0 eingestellt. Dies erreicht man im IIS Manager unter Application Pools (1.), dort den entsprechenden Application Pool auswählen, der im obigen Schritt ermittelt wurde (bei mir sba) (2.), dann in den Basic Settings (3.) die Framework Version ändern und mit nem Klick auf OK bestätigen (4.). Durch diese Änderung wird der Application Pool automatisch „recycled“ und die Seite kann aktualisiert werden im Browser.

07_Change_IIS

Et Voià! Die Website der SBA funktioniert wieder und die korrekte Version ist bereitgestellt.

08_Fertig

 

Viel Erfolg!

Rouven

 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.